gordiplom.ru

Рефераты, дипломные работы и прочие учебные работы.

Системы принятия решений, оптимизация в Excel и базы данных Access

Системы принятия решений, оптимизация в Excel и базы данных Access

Системы искусственного интеллекта – это программная имитация человеческого мышления.

Системы искусственного интеллекта, которые разработаны для конкретной предметной области, называются экспертной системой или системой принятия решений.

Экспертные системы применяются в медицине (диагностика болезни), в военном деле (распознавание целей), бизнеса (системы поддержки и принятия решений). В разработке систем принимают участие: 1) эксперты в данной области, они разрабатывают наиболее важные характеристики предметной области. Они называют факты или атрибуты, а так же вырабатывают правила принятия решения. 2) Специалисты инженерии знаний. Они разрабатывают реализацию экспертной системы на компьютере. Факты и правила принятия решений хранятся в специальной организованной области памяти, которая называется базой знаний.

Информация о состоянии предметной области в данный момент, которая представляется экспертной системе для анализа, называется базой данных.

Задание 1 Разработать систему принятия решения для аттестации знаний студентов по разделу «Текстовой процессор Word ». База знаний имеет вид:

№ п/п Атрибут Весовой фактор атрибута
1 Умеет создавать документ 20
2 Умеет редактировать документ 30
3 Умеет форматировать документ 30
4 Умеет создавать документ со списками 30
5 Умеет работать с табуляторами 30
6 Умеет работать с колонками 30
7 Умеет работать с колонтитулами 30
8 Умеет нумеровать страницы 30
9 Умеет работать с панелью «рисование» 30
10 Умеет вставлять рисунки и схемы 30
11 Умеет работать с таблицами 60
12 Умеет вырезать и вставлять рисунки с использованием редактора Paint 60
13 Умеет создавать макросы 50
14 Умеет проводить слияние документов из разных приложений 70
Правила вывода: - Если студент набрал меньше 330 баллов, оценка «неудовлетворительно» - Если сумма баллов 330-390 – оценка «удовлетворительно». - При сумме баллов 390-440 – оценка «хорошо». - Если сумма баллов больше 440 – оценка «отлично». Решение: Разработка системы принятия решений включает три этапа: 1. Разработка дерева принятия решений. 2. Разработка базы данных. 3. Компьютерная реализация. 1. Разработка дерева принятия решений. Это дерево строится на основе правил вывода и представляет собой графическое изображение схемы решений.

Дерево имеет вершины и ветви.

Вершины обозначаются либо окружностями или эллипсами (проверка условий), либо прямоугольниками (принятие решений). Ветви соединяют вершины и показывают направление решений. Сумма баллов абитуриента – S . либо SHAPE * MERGEFORMAT

S 330
Неудовлетв.
S 390
Удовлетвор.
S 440
Хорошо
Отлично
2. База данных создается на основе базы знаний, в которую добавляется столбец ответов, если ответ положительный весовой фактор атрибута сохраняется, если отрицательный фактор обнуляется. 3. Реализация экспертной системы в электронной таблице. В ячейки A 1: D 3 введем заголовки и комментарии. В A 4: D 17 размещается база знаний. В C4 : C17 – ответы. В D 4: D 17 вводим формулы для обработки ответов. в D 4 вводится формула =B4*C4 копируем ее в ячейки D 5: D 17 В строке 18 вычислим суммарный весовой фактор S . В 20-ой введем формулу для принятия решения.
A B C D
1 Оценка знаний абитуриента
2 Атрибут Весовой фактор атрибута Ответ Весовой фактор ответа
3 База знаний База данных
4 Умеет создавать документ 20 1 20
5 Умеет редактировать документ 30 1 30
6 Умеет форматировать документ 30 1 30
7 Умеет создавать документ со списком ами 30 1 30
8 Умеет работать с табуляторами 30 0 0
9 Умеет работать с колонками 30 0 0
10 Умеет работать с колонтитулами 30 1 30
11 Умеет нумеровать страницы 30 1 30
12 Умеет работать с панелью «рисование» ние» 30 1 30
13 Умеет вставлять рисунки и схемы 30 1 30
14 Умеет работать с таблицами 60 1 60
15 Умеет вырезать и вставлять рисунки с использованием редактора Paint 60 1 60
16 Умеет создавать макросы 50 1 50
17 Умеет проводить слияние документов из разных приложений 70 1 70
18 Суммарный весовой фактор S 400
19 Принятие решения
20 хорошо
A B C D
1 Оценка знаний абитуриента
2 Атрибут Весовой фактор атрибута Ответ Весовой фактор ответа
3 База знаний База данных
4 Умеет создавать документ 20 1 =B4*C4
5 Умеет редактировать документ 30 1 =B5*C5
6 Умеет форматировать документ 30 1 =B6*C6
7 Умеет создавать документ со списком ами 30 1 =B7*C7
8 Умеет работать с табуляторами 30 0 =B8*C8
9 Умеет работать с колонками 30 0 =B9*C9
10 Умеет работать с колонтитулами 30 1 =B10*C10
11 Умеет нумеровать страницы 30 1 =B11*C11
12 Умеет работать с панелью «рисование» ние» 30 1 =B12*C12
13 Умеет вставлять рисунки и схемы 30 1 =B13*C13
14 Умеет работать с таблицами 60 1 =B14*C14
15 Умеет вырезать и вставлять рисунки с использованием редактора Paint 60 1 =B15*C15
16 Умеет создавать макросы 50 1 =B16*C16
17 Умеет проводить слияние документов из разных приложений 70 1 =B17*C17
18 Суммарный весовой фактор S 400 =СУММ(D4:D16)
19 Принятие решения
20 =ЕСЛИ( D 18 D 18 D 18
2. Оптимизация управленческих и экономических решений. При решении многих задач в экономике и управлении возникает проблема найти оптимальные решения. Для решения существуют специальные разделы математики (линейное программирование). В Excel для нахождения оптимального решения существует специальный режим «Поиск решения». Задание 2. Администрации фирмы требуется определить штат и составить график работы обслуживающего персонала. При этом необходимо обеспечить следующие условия: - Каждый сотрудник должен иметь пять рабочих дней в неделю и два выходных подряд; - Все сотрудники имеют заработную плату 230 руб. в день; - Исходя из специфики работы фирмы, имеются требования к минимальному количеству работающих сотрудников для каждого дня недели.
День недели понедельник вторник среда четверг пятница суббота воскресенье
Требуемое число сотрудников 25 30 35 25 25 10 7
На текущий момент в фирме работает 45 человек.

Определить штат сотрудников, обеспечивающий выполнение всех условий при минимальном фонде заработной платы.

Решение включает в себя три этапа: 1. Построение математической модели. 2. Построение начального плана. 3. Оптимизация решения. 1 этап. 1.1. Определим возможные режимы работы и занесем их в 1-ый столбец таблицы №1.

Выходные дни Число имеющих этот график ПН ВТ СР ЧТ ПТ СБ ВС
ПН, ВТ 0 0 1 1 1 1 1
ВТ, СР 1 0 0 1 1 1 1
СР, ЧТ 1 1 0 0 1 1 1
ЧТ, ПТ 1 1 1 0 0 1 1
ПТ, СБ 1 1 1 1 0 0 1
СБ, ВС 1 1 1 1 1 0 0
ВС, ПН 0 1 1 1 1 1 0
Число выходов по графику 45 31 33 35 33 31 31 31
Требуется 45 25 30 35 25 25 10 7
Зарплата 230
Число выходов 225
Целевая 51750
Составим предварительный график работы. 1.2. Обозначим – число сотрудников, имеющих выходные в ПН т ВТ; в ВТ, СР; – СР, ЧТ; – ЧТ, ПТ; – ПТ, СБ; – ВС, ПН. Согласно условиям задачи большего всего сотрудников должны работать в среду, значит, число отдыхающих в этот день должно быть меньше всего.

Например, возьмем Занесем значения Х во второй столбец таблицы. 1.3. Введем индексы выхода на работу в остальные столбцы, где, если это “1” –рабочий день, a “0” – выходной день. 1.4. Рассчитаем число выходов на работу каждый день. Для расчета числа выходов в ПН нужно перемножить и сложить значения столбца Х столбца ПН. И так далее. 1.5. Рассчитываем целевую функцию задачи – фонд зарплаты за неделю. Z = B Где В – зарплата сотрудника за день, а К – число выходов на работу за неделю. К=31+33+35+33+31+31+31=225 Z =225 На модель накладываются следующие ограничения: 1) переменные Х не отрицательные. 2) Х – целые 3) Количество выходящих на работу по графику не может быть меньше требуемого числа сотрудников.

A B C D E F G H I
1 График работы
2 Выходные число имеющих этот график ПН ВТ СР ЧТ ПТ СБ ВС
3 ПН, ВТ 7 0 0 1 1 1 1 1
4 ВТ, СР 5 1 0 0 1 1 1 1
5 СР, ЧТ 5 1 1 0 0 1 1 1
6 ЧТ, ПТ 7 1 1 1 0 0 1 1
7 ПТ, СБ 7 1 1 1 1 0 0 1
8 СБ, ВС 7 1 1 1 1 1 0 0
9 ВС, ПН 7 0 1 1 1 1 1 0
10 Число выходов по графику =СУММ(B3:B9) =СУММПРОИЗВ($ B 3:$ B 9; C 3: C 9) =СУММПРОИЗВ(:;D3:D9) =СУММПРОИЗВ($ B 3:$ B 9; E 3: E 9) =СУММПРОИЗВ(:; F 3: F 9) =СУММПРОИЗВ(:; G 3: G 9) =СУММПРОИЗВ(:; H 3: H 9) =СУММПРОИЗВ(:; I 3: I 9)
11 Требуется 45 25 30 35 25 25 10 7
12 Зарплата за день 230
13 Число выходов за неделю =СУММ(C10:I10)
14 Целевая функция =B12*C13
15
2 этап.

Построение начального плана. 2.1. В ячейках А1: I 9 разместим начальный график работы согласно таблице №1. 2.2. Расчет числа выхода по графику: а) в ячейке B 10 вычислим общее число сотрудников фирмы необходимое для данного графика. б) в С10 введем формулу для вычисления количества сотрудников, работающих в понедельник. в) копируем формулу из ячейки C 10 в ячейки D 10: I 10. 2.3. В строку 11 заносим требования к графику работы согласно условиям задачи. 3 этап.

Оптимизация решения. 3.1. Запускаем режим «Поиск решения» (сервис-поиск решения) 3.2. В окно поиска решения вводим: - в целевую ячейку $14 - установить минимальные значения - изменяя ячейки В3:В9 3.3. Добавить ограничения: - В3:В9 >=0 - B 3: B 9 – целые - C 10: C 10>= C 11: I 11 После проделанных действий щелкаем на «Выполнить»! Вид таблицы и результаты:

A B C D E F G H I
1 График работы
2 Выходные число имеющих этот график ПН ВТ СР ЧТ ПТ СБ ВС
3 ПН, ВТ 5 0 0 1 1 1 1 1
4 ВТ, СР 0 1 0 0 1 1 1 1
5 СР, ЧТ 0 1 1 0 0 1 1 1
6 ЧТ, ПТ 3 1 1 1 0 0 1 1
7 ПТ, СБ 7 1 1 1 1 0 0 1
8 СБ, ВС 15 1 1 1 1 1 0 0
9 ВС, ПН 5 0 1 1 1 1 1 0
10 Число выходов по графику 35 25 30 35 32 25 13 15
11 Требуется 45 25 30 35 25 25 10 7
12 Зарплата за день 230
13 Число выходов за неделю 175
14 Целевая функция 40250
4. Базы данных. База данных – это поименованная область памяти для хранения структурированных данных.

Система управления БД это комплекс программных и языковых средств для создания и ведения БД. Структурные элементы баз данных.

Модель данных – это структура хранения информации в БД. Имеется 3 модели данных : - иерархическая - сетевая - реляционная (ввиде двумерных таблиц) Наиболее распространенная СУБД ( FoxPro , Paradox , Access ) реляционные.

Основными элементами реляционных БД являются : поле, запись, отношение, файл, ключ. Поле – логическая единица записи информации (один столбец таблицы). При создании БД каждое поле описывают, указывая следующие характеристики: - имя - тип информации (текстовой, числовой, дата/время) - длина (число символов в столбце) - точность (только для дробных чисел) - формат (для дата/время) Запись – это совокупность логически объединенных полей (1 строка таблицы). Отношение – это совокупность экземпляров записей одной структуры.(таблица) Файл – совокупность объектов БД. Например, в Access основными объектами являются: - таблицы (для хранения информации) - формы (для просмотра и ввода данных) - запросы (для отбора данных) - отчеты (для подготовки к печати) Ключ это поле, по которому можно найти любую запись БД. Основные этапы проектирования баз данных.

оценка мотоцикла в Калуге
оценка патента в Туле
экспертиза оценки ущерба от залива в Липецке

Менеджмент (Теория управления и организации)

Экономическая теория, политэкономия, макроэкономика

Микроэкономика, экономика предприятия, предпринимательство

Политология, Политистория

Геология

Материаловедение

Международные экономические и валютно-кредитные отношения

Философия

Медицина

География, Экономическая география

Авиация

Педагогика

Экономика и Финансы

Государственное регулирование, Таможня, Налоги

Архитектура

Уголовное право

Административное право

Бухгалтерский учет

Теория государства и права

Литература, Лингвистика

Компьютерные сети

Радиоэлектроника

Технология

Право

Прокурорский надзор

Гражданское право

Промышленность и Производство

Музыка

История

Финансовое право

История отечественного государства и права

Нероссийское законодательство

Экскурсии и туризм

Пищевые продукты

Культурология

Уголовное и уголовно-исполнительное право

Конституционное (государственное) право России

Банковское право

Маркетинг, товароведение, реклама

Программирование, Базы данных

Астрономия

Техника

Химия

Программное обеспечение

Физкультура и Спорт, Здоровье

Религия

Компьютеры, Программирование

Уголовный процесс

Законодательство и право

Ценные бумаги

Компьютеры и периферийные устройства

Военное дело

Здоровье

Математика

Физика

Транспорт

Охрана природы, Экология, Природопользование

Космонавтика

Геодезия

Психология, Общение, Человек

Биология

Искусство

Разное

История государства и права зарубежных стран

Муниципальное право России

Гражданское процессуальное право

Социология

Сельское хозяйство

Налоговое право

Римское право

Трудовое право

Охрана правопорядка

Конституционное (государственное) право зарубежных стран

Металлургия

Международное право

Криминалистика и криминология

Правоохранительные органы

Страховое право

Ветеринария

Физкультура и Спорт

Арбитражно-процессуальное право

Нотариат

Астрономия, Авиация, Космонавтика

Историческая личность

Банковское дело и кредитование

Подобные работы

Прогнозирование на основе аппарата нейронных сетей

echo "Рассмотрена структура и особенности каждой из моделей. Перечислены основные задачи решаемые на основе НС, описаны способы реализации НС. Проведен анализ известных моделей НС с точки зрения реше

Системы принятия решений, оптимизация в Excel и базы данных Access

echo "Системы искусственного интеллекта – это программная имитация человеческого мышления. Системы искусственного интеллекта, которые разработаны для конкретной предметной области, называются эксперт

Прикладное программирование, 1 семестр

echo "Архитектура компьютеров IBM AT и микропроцессоров Intel принципиально устарела. Система Windows стала сверхуниверсальной, что приводит к чрезвычайному замедлению работы компьютеров. За кризис в

Классификация баз данных

echo "Системы управления базами данных можно классифицировать по способу установления связей между данными, характеру выполняемых ими функций, сфере применения, числу поддерживаемых моделей данных, ха

Оптимизация плана работ по отладке программных продуктов

echo "Руководство компаний не в состоянии отслеживать конкретную деятельность подчиненных. Самая главная проблема в том, что руководящий состав не имеет четкого представления о качестве выпускаемого и